函数接口定义:
struct ListNode *createlist();
函数createlist
利用scanf
从输入中获取一系列正整数,当读到−1时表示输入结束。按输入数据的逆序建立一个链表,并返回链表头指针。链表节点结构定义如下:
struct ListNode {
int data;
struct ListNode *next;
};
裁判测试程序样例:
#include <stdio.h>
#include <stdlib.h>
struct ListNode {
int data;
struct ListNode *next;
};
struct ListNode *createlist();
int main()
{
struct ListNode *p, *head = NULL;
head = createlist();
for ( p = head; p != NULL; p = p->next )
printf("%d ", p->data);
printf("\n");
return 0;
}
/* 你的代码将被嵌在这里 */
输入样例:
1 2 3 4 5 6 7 -1
输出样例:
7 6 5 4 3 2 1
自己想的是,正常建立链表,然后用类似于冒泡排序的做法倒序;写完后看到别人的贴子用头插法,感觉好厉害。
struct ListNode *createlist(){
struct ListNode *head,*tail,*p,*q;
head=tail=NULL;
int n,ctn=0,i,j;
while(scanf("%d",&n)&&n!=-1){
ctn++;
p=(struct ListNode *)malloc(sizeof(struct ListNode ));
p->data=n;
p->next=NULL;
if(head==NULL){
head=tail=p;
}else{
tail->next=p;
tail=p;
}
}
int t;
for(i=0;i<ctn-1;i++){
p=head;
for(j=0,q=p->next;j<ctn-i-1;p=p->next,q=p->next,j++){
t=p->data;
p->data=q->data;
q->data=t;
}
}
return head;
}