Elevator

Elevator

Time Limit : 2000/1000ms (Java/Other) Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 33 Accepted Submission(s) : 17
Problem Description
The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input
There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.

Output
Print the total time on a single line for each test case.

Sample Input
1 2
3 2 3 1
0

Sample Output
17
41

Author
ZHENG, Jianqiang

Source
ZJCPC2004

#include<stdio.h>
int main(int argc, const char* argv[])
{
	int sum, num = 0,floor,floor1 = 0;;
	while (scanf("%d", &num) != EOF)
	{
		if (num == 0)
			break;
		sum = 0;
		floor = 0;
		for (int i = 0; i < num; i++)
		{
			scanf("%d", &floor1);
			if (floor > floor1)
				sum += 4 * (floor - floor1) + 5;
			else if (floor < floor1)
				sum += 6 * (floor1 - floor) + 5;
			else
				sum += 5;
			floor = floor1;
		}
		printf("%d\n", sum);
	}
	return 0;
}

具体没什么难度,注意一下题目细节就可以

上一篇:PostgreSQL数据库管理 第三章实例管理与管理工具


下一篇:COMP2401