Problem Description
The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.
For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.
Input
There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.
Output
Print the total time on a single line for each test case.
Sample Input
1 2
3 2 3 1
0
Sample Output
17
41
Author
ZHENG, Jianqiang
Source
ZJCPC2004
题意:上下电梯问题,上6秒,下4秒,中间停5秒!!电梯一开始在第0层,当要求被满足时,不必返回到第1层 。输入一系列的n,接着输入n 个数,代表电梯停留在哪层,当n为0时,结束输入。
代码:
#include<stdio.h>
int main()
{
int n;
while(scanf("%d",&n)){
if(n==0)
break;
int a,s=0;
int f=0;
while(n--){
scanf("%d",&a);
if(a>f){
s+=(a-f)*6;
}
else{
s-=(a-f)*4;
}
s+=5;
f=a;
}
printf("%d\n",s);
}
return 0;
}