本题要求实现两个函数,分别将读入的数据存储为单链表、将链表中偶数值的结点删除。链表结点定义如下:
struct ListNode {
int data;
struct ListNode *next;
};
函数接口定义:
struct ListNode *createlist();
struct ListNode *deleteeven( struct ListNode *head );
函数createlist
从标准输入读入一系列正整数,按照读入顺序建立单链表。当读到−1时表示输入结束,函数应返回指向单链表头结点的指针。
函数deleteeven
将单链表head
中偶数值的结点删除,返回结果链表的头指针。
裁判测试程序样例:
#include <stdio.h>
#include <stdlib.h>
struct ListNode {
int data;
struct ListNode *next;
};
struct ListNode *createlist();
struct ListNode *deleteeven( struct ListNode *head );
void printlist( struct ListNode *head )
{
struct ListNode *p = head;
while (p) {
printf("%d ", p->data);
p = p->next;
}
printf("\n");
}
int main()
{
struct ListNode *head;
head = createlist();
head = deleteeven(head);
printlist(head);
return 0;
}
/* 你的代码将被嵌在这里 */
输入样例:
1 2 2 3 4 5 6 7 -1
结尾无空行
输出样例:
1 3 5 7
结尾无空行
struct ListNode *createlist()
{
struct ListNode *head,*p1,*tail;
int x;
head=(struct ListNode *)malloc(sizeof(struct ListNode));
p1=tail=(struct ListNode *)malloc(sizeof(struct ListNode));
p1->next=tail->next=head->next=NULL;
scanf("%d",&x);
while(x!=-1)
{
p1->data=x;
if(head->next==NULL) head->next=p1;
else
{
tail->next=p1;
tail=p1;
}
p1=(struct ListNode *)malloc(sizeof(struct ListNode));
p1->next=NULL;
scanf("%d",&x);
}
return head;
}
struct ListNode *deleteeven(struct ListNode *head)
{
struct ListNode *p1,*p2;
p2=head;
p1=head->next;
while(p1!=NULL)
{
if(p1->data%2==0)
{
p2->next=p1->next;
}
else
p2=p2->next;
p1=p1->next;
}
return head->next;
}