2019三月PAT甲级 7-2 Anniversary

7-2 Anniversary (25 分)

Zhejiang University is about to celebrate her 122th anniversary in 2019. To prepare for the celebration, the alumni association (校友会) has gathered the ID's of all her alumni. Now your job is to write a program to count the number of alumni among all the people who come to the celebration.

Input Specification:

Each input file contains one test case. For each case, the first part is about the information of all the alumni. Given in the first line is a positive integer N (≤10​5​​). Then N lines follow, each contains an ID number of an alumnus. An ID number is a string of 18 digits or the letter X. It is guaranteed that all the ID's are distinct.

The next part gives the information of all the people who come to the celebration. Again given in the first line is a positive integer M(≤10​5​​). Then M lines follow, each contains an ID number of a guest. It is guaranteed that all the ID's are distinct.

Output Specification:

First print in a line the number of alumni among all the people who come to the celebration. Then in the second line, print the ID of the oldest alumnus -- notice that the 7th - 14th digits of the ID gives one's birth date. If no alumnus comes, output the ID of the oldest guest instead. It is guaranteed that such an alumnus or guest is unique.

Sample Input:

5
372928196906118710
610481197806202213
440684198612150417
13072819571002001X
150702193604190912
6
530125197901260019
150702193604190912
220221196701020034
610481197806202213
440684198612150417
370205198709275042

Sample Output:

3
150702193604190912
#include <iostream>
#include <cstdio>
#include <sstream>
#include <vector>
#include <string>
#include <set>
#include <queue>
#include <map>
#include <unordered_map>
#include <unordered_set>
#include <cmath>
#include <cctype>
#include <algorithm>
#include <functional>
using namespace std;

int main() {
	int N; cin >> N;
	unordered_set<string> alumni;
	for (int i = 0; i < N; ++i) {
		string s; cin >> s;
		alumni.insert(s);
	}

	int M; cin >> M;
	string oldest_alumnus = "", oldest_guest = "";
	int cnt = 0;
	for (int i = 0; i < M; ++i) {
		string s; cin >> s;
		if (alumni.find(s) != alumni.end()) { //is an alumnus
			++cnt;
			if (oldest_alumnus == "" || s.substr(7, 8) < oldest_alumnus.substr(7, 8))
				oldest_alumnus = s;
		} // is a guest
		else {
			if (oldest_guest == "" || s.substr(7, 8) < oldest_guest.substr(7, 8))
				oldest_guest = s;
		}
	}

	cout << cnt << endl;
	cout << (cnt == 0 ? oldest_guest : oldest_alumnus) << endl;

	return 0;
}

 

 

 

上一篇:springboot集成rabbitmq的一些坑


下一篇:2019虫师自动化 Python接口自动化虫师 robotframework虫师 虫师接口自动化源码下载