The Missing Number

                                       7-1 The Missing Number (20 分)

Given N integers, you are supposed to find the smallest positive integer that is NOT in the given list.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10​5​​). Then N integers are given in the next line, separated by spaces. All the numbers are in the range of int.

Output Specification:

Print in a line the smallest positive integer that is missing from the input list.

Sample Input:

10
5 -25 9 6 1 3 4 2 5 17

Sample Output:

7

思路:将n个数插入到集合s中,然后i从1向后遍历,如果i不在集合s中输出i程序结束,否则i++

上AC代码:

#include <iostream>
#include<bits/stdc++.h>
using namespace std;

int main()
{
    set<int> s;
    int n,e;
    cin>>n;
    for(int i=0;i<n;i++)
    {
        cin>>e;
        s.insert(e);
    }
    int i=1;
    while(i)
    {
        if(s.find(i)==s.end())
        {
            cout<<i<<endl;
            return 0;
        }
        i++;
    }
    return 0;
}

 

上一篇:sql 审计(审核)


下一篇:Resolution in《The Java Virtual Machine Specification Java SE 7 Edition》