Trie字符串统计

维护一个字符串集合,支持两种操作:

    I x 向集合中插入一个字符串 x;
    Q x 询问一个字符串在集合中出现了多少次。

共有 N个操作,输入的字符串总长度不超过 10^5,字符串仅包含小写英文字母。

输入格式
第一行包含整数 N,表示操作数。
接下来 N行,每行包含一个操作指令,指令为 I x 或 Q x 中的一种。

输出格式
对于每个询问指令 Q x,都要输出一个整数作为结果,表示 x在集合中出现的次数。
每个结果占一行。

数据范围
1≤N≤2∗10^4

输入样例:

5
I abc
Q abc
Q ab
I ab
Q ab

输出样例:

1
0
1

算法一:用标准库,利用标准库里面的集合即可

#include <iostream>
#include <cstring>
#include <algorithm>
#include <set>
#include <unordered_set>

using namespace std;

unordered_multiset <string> se;

int main()
{
    int t;
    cin >> t;
    while(t --)
    {
        char ch;
        string s;
        cin >> ch >> s;
        if(ch == 'I') se.insert(s);
        else printf("%d\n", se.count(s));
    }
    return 0;
}

算法二:trie树

Trie字符串统计

 

 以树存储,处处有路可走,最后查找到有标记。

 

#include <iostream>

using namespace std;

const int N = 100010;

int son[N][26], cnt[N], idx;
char str[N];

void insert(char *str)//插入操作
{
    int p = 0;
    for (int i = 0; str[i]; i ++ )
    {
        int u = str[i] - 'a';//把每个字符挨个放入
        if (!son[p][u]) son[p][u] = ++ idx;//作为tire树的路径
        p = son[p][u];
    }
    cnt[p] ++ ;//在结尾处标记出现了几次
}

int query(char *str)
{
    int p = 0;
    for (int i = 0; str[i]; i ++ )
    {
        int u = str[i] - 'a';//把每个字符挨个放入
        if (!son[p][u]) return 0;//tire树没有路径了
        p = son[p][u];
    }
    return cnt[p];
}

int main()
{
    int n;
    scanf("%d", &n);
    while (n -- )
    {
        char op[2];
        scanf("%s%s", op, str);
        if (*op == 'I') insert(str);
        else printf("%d\n", query(str));
    }

    return 0;
}

 

上一篇:CF380C Sereja and Brackets 题解


下一篇:小程序生命周期函数、组件