1038 Recover the Smallest Number (30 分)

1038 Recover the Smallest Number (30 分)

Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given { 32, 321, 3214, 0229, 87 }, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.

Input Specification:

Each input file contains one test case. Each case gives a positive integer N (≤10​4​​) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the smallest number in one line. Notice that the first digit must not be zero.

Sample Input:

5 32 321 3214 0229 87

Sample Output:

22932132143287

题意:输入n个非负数数,求这n个数字组成的最小数

分析:贪心,对各个字符串排序,如果直接从小到大排序,会出现错误,比如32和321,排序后合并为32321,显然32132比它更小。

注意到这点题目就好做了,对sort自定义比较函数,a+b<b+a,那么让a+b在前面即可。

有个测试点是去掉前导0的时候可能字符串长度会变成0,此时直接输出0。

 /**
 * Copyright(c)
 * All rights reserved.
 * Author : Mered1th
 * Date : 2019-02-26-11.49.45
 * Description : A1038
 */
 #include<cstdio>
 #include<cstring>
 #include<iostream>
 #include<cmath>
 #include<algorithm>
 #include<string>
 #include<unordered_set>
 #include<map>
 #include<vector>
 #include<set>
 using namespace std;
 ;
 string a[maxn];
 bool cmp(string a,string b){
     return a+b<b+a;  //如果a+b<b+a,把a+b排在前面
 }
 int main(){
 #ifdef ONLINE_JUDGE
 #else
     freopen("1.txt", "r", stdin);
 #endif
     int n;
     cin>>n;
     ;i<n;i++){
         cin>>a[i];
     }
     sort(a,a+n,cmp);
     string ans="";
     ;i<n;i++){
         ans+=a[i];
     }
     ]=='){
         ans.erase(ans.begin());
     }
     if(ans.size()) cout<<ans;
     ";
     ;
 }
 
上一篇:selenium C#下的zencart自动化测试(WFloginUrlPayment)环境4.0


下一篇:winscp 怎么用私钥文件登录的,以.ppk结尾的密钥文件