POJ1269 Intersecting Lines 2017-04-16 19:43 50人阅读 评论(0) 收藏

Intersecting Lines
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 15478   Accepted: 6751

Description

We all know that a pair of distinct points on a plane defines a line and that a pair of lines on a plane will intersect in one of three ways: 1) no intersection because they are parallel, 2) intersect in a line because they are on top of one another (i.e. they
are the same line), 3) intersect in a point. In this problem you will use your algebraic knowledge to create a program that determines how and where two lines intersect. 

Your program will repeatedly read in four points that define two lines in the x-y plane and determine how and where the lines intersect. All numbers required by this problem will be reasonable, say between -1000 and 1000. 

Input

The first line contains an integer N between 1 and 10 describing how many pairs of lines are represented. The next N lines will each contain eight integers. These integers represent the coordinates of four points on the plane in the order x1y1x2y2x3y3x4y4.
Thus each of these input lines represents two lines on the plane: the line through (x1,y1) and (x2,y2) and the line through (x3,y3) and (x4,y4). The point (x1,y1) is always distinct from (x2,y2). Likewise with (x3,y3) and (x4,y4).

Output

There should be N+2 lines of output. The first line of output should read INTERSECTING LINES OUTPUT. There will then be one line of output for each pair of planar lines represented by a line of input, describing how the lines intersect: none, line, or point.
If the intersection is a point then your program should output the x and y coordinates of the point, correct to two decimal places. The final line of output should read "END OF OUTPUT".

Sample Input

5
0 0 4 4 0 4 4 0
5 0 7 6 1 0 2 3
5 0 7 6 3 -6 4 -3
2 0 2 27 1 5 18 5
0 3 4 0 1 2 2 5

Sample Output

INTERSECTING LINES OUTPUT
POINT 2.00 2.00
NONE
LINE
POINT 2.00 5.00
POINT 1.07 2.20
END OF OUTPUT

Source

——————————————————————————————————————题目的意思是给出4个坐标确定两条直线,问这两条直线的关系平行or重合or相交(求焦点)

先根据斜率判关系(斜率不存在特判)再套几何模板即可

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <cmath>
#include <map>
#include <set>
#include <stack>
#include <queue>
#include <vector>
#include <bitset> using namespace std; #define LL long long
const int INF=0x3f3f3f3f; struct Point
{
double x,y;
};
typedef struct Point point; point f(point u1,point u2,point v1,point v2)
{
point ret=u1;
double t=((u1.x-v1.x)*(v1.y-v2.y)-(u1.y-v1.y)*(v1.x-v2.x))
/((u1.x-u2.x)*(v1.y-v2.y)-(u1.y-u2.y)*(v1.x-v2.x));
ret.x+=(u2.x-u1.x)*t;
ret.y+=(u2.y-u1.y)*t;
return ret;
} int main()
{
int T;
while(~scanf("%d",&T))
{
printf("INTERSECTING LINES OUTPUT\n");
while(T--)
{
point u1,u2,v1,v2;
scanf("%lf%lf%lf%lf%lf%lf%lf%lf",&u1.x,&u1.y,&u2.x,&u2.y,&v1.x,&v1.y,&v2.x,&v2.y);
if(u1.x==u2.x||v1.x==v2.x)
{
if(u1.x==u2.x&&v1.x==v2.x)
{
if(u1.x==v1.x) printf("LINE\n");
else printf("NONE\n");
}
else if(u1.x==u2.x)
{
double k2=(v1.y-v2.y)/(v1.x-v2.x);
printf("POINT %.2f %.2f\n",u1.x,v2.y-k2*v2.x+k2*u1.x);
}
else
{
double k1=(u1.y-u2.y)/(u1.x-u2.x);
printf("POINT %.2f %.2f\n",v1.x,u2.y-k1*u2.x+k1*v1.x);
}
}
else
{
double k1=(u1.y-u2.y)/(u1.x-u2.x);
double k2=(v1.y-v2.y)/(v1.x-v2.x);
if(k1!=k2)
{
point ans=f(u1,u2,v1,v2);
printf("POINT %.2f %.2f\n",ans.x,ans.y);
}
else
{
double ans1=k1*v1.x+u1.y-k1*u1.x;
if(ans1==v1.y)
printf("LINE\n");
else
printf("NONE\n");
}
}
}
printf("END OF OUTPUT\n");
}
return 0;
}
上一篇:JS闭包(转载加整理)


下一篇:Python多进程应用