1120 Friend Numbers (20 分)

1120 Friend Numbers (20 分)

Two integers are called "friend numbers" if they share the same sum of their digits, and the sum is their "friend ID". For example, 123 and 51 are friend numbers since 1+2+3 = 5+1 = 6, and 6 is their friend ID. Given some numbers, you are supposed to count the number of different frind ID's among them.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N. Then N positive integers are given in the next line, separated by spaces. All the numbers are less than 10​4​​.

Output Specification:

For each case, print in the first line the number of different frind ID's among the given integers. Then in the second line, output the friend ID's in increasing order. The numbers must be separated by exactly one space and there must be no extra space at the end of the line.

Sample Input:

8
123 899 51 998 27 33 36 12

Sample Output:

4
3 6 9 26

题意:统计数的各位数字之和,并升序输出

分析:水题
 /**
 * Copyright(c)
 * All rights reserved.
 * Author : Mered1th
 * Date : 2019-02-27-21.33.59
 * Description : A1120
 */
 #include<cstdio>
 #include<cstring>
 #include<iostream>
 #include<cmath>
 #include<algorithm>
 #include<string>
 #include<unordered_set>
 #include<map>
 #include<vector>
 #include<set>
 using namespace std;
 ;
 set<int> ans;
 int main(){
 #ifdef ONLINE_JUDGE
 #else
     freopen("1.txt", "r", stdin);
 #endif
     int n;
     cin>>n;
     string str;
     ;i<n;i++){
         cin>>str;
         ;
         int len=str.size();
         ;j<len;j++){
             sum+=str[j]-';
         }
         ans.insert(sum);
     }
     printf("%d\n",ans.size());
     for(auto it=ans.begin();it!=ans.end();it++){
         if(it!=ans.begin()) printf(" %d",*it);
         else printf("%d",*it);
     }
     ;
 }


上一篇:webstorm前端开发工具vue环境配置及运行项目


下一篇:Win10系统的SurfacePro4如何重装系统-1 SurfacePro专用的PE