Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 56958 | Accepted: 16464 |
Description
- Every candidate can place exactly one poster on the wall.
- All posters are of the same height equal to the height of the wall; the width of a poster can be any integer number of bytes (byte is the unit of length in Bytetown).
- The wall is divided into segments and the width of each segment is one byte.
- Each poster must completely cover a contiguous number of wall segments.
They have built a wall 10000000 bytes long (such that there is enough place for all candidates). When the electoral campaign was restarted, the candidates were placing their posters on the wall and their posters differed widely in width. Moreover, the candidates
started placing their posters on wall segments already occupied by other posters. Everyone in Bytetown was curious whose posters will be visible (entirely or in part) on the last day before elections.
Your task is to find the number of visible posters when all the posters are placed given the information about posters' size, their place and order of placement on the electoral wall.
Input
were placed. The i-th line among the n lines contains two integer numbers li and ri which are the number of the wall segment occupied by the left end and the right end of the i-th poster, respectively. We know
that for each 1 <= i <= n, 1 <= li <= ri <= 10000000. After the i-th poster is placed, it entirely covers all wall segments numbered li, li+1
,... , ri.
Output
The picture below illustrates the case of the sample input.
Sample Input
1
5
1 4
2 6
8 10
3 4
7 10
Sample Output
4
Source
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
using namespace std;
struct li{int x,y;}a[10001];
int n,ans,col[44001],tot[10001],s1[22001],s2[33001],n1,n2;
int bin(int k)
{
int l=1,r=n2;
while(l<=r){
int m=(l+r)>>1;
if(s2[m]==k) return m;
if(s2[m]<k) l=m+1;
else r=m-1;
}
return -1;
}
void pushdown(int k)
{
if(col[k]!=-1){
col[k<<1]=col[k<<1|1]=col[k];
col[k]=-1;
}
}
void update(int s,int t,int k,int wantl,int wantr,int p)
{
if(wantl<=s&&t<=wantr){
col[k]=p;
return ;
}pushdown(k);
int m=(s+t)>>1;
if(wantl<=m)update(s,m,k<<1,wantl,wantr,p);
if(wantr>m)update(m+1,t,k<<1|1,wantl,wantr,p);
}
void query(int s,int t,int k)
{
if(col[k]!=-1){
if(!tot[col[k]])ans++;
tot[col[k]]=1;
return ;
}
if(!(s^t))return ;
int m=(s+t)>>1;
query(s,m,k<<1);
query(m+1,t,k<<1|1);
}
int main()
{
int t;
scanf("%d",&t);
for(;t;t--){
scanf("%d",&n);
n1=0;
for(int i=1;i<=n;i++){
scanf("%d%d",&a[i].x,&a[i].y);
s1[++n1]=a[i].x;
s1[++n1]=a[i].y;
}
sort(s1+1,s1+1+n1);
n2=0;
for(int i=1;i<=n1;i++)
if(s1[i-1]^s1[i])s2[++n2]=s1[i];
//for(int i=n2;i>=1;i--)
// if(s2[i]^(s2[i-1]+1))s2[++n2]=s2[i-1]+1;
//sort(s2+1,s2+1+n2);
memset(col,-1,sizeof(col));
for(int i=1;i<=n;i++){
a[i].x=bin(a[i].x);
a[i].y=bin(a[i].y);
update(1,n2,1,a[i].x,a[i].y,i);
}ans=0;
memset(tot,0,sizeof(tot));
query(1,n2,1);
printf("%d\n",ans);
}
return 0;
}