1071 Speech Patterns (25 分)

1071 Speech Patterns (25 分)

People often have a preference among synonyms of the same word. For example, some may prefer "the police", while others may prefer "the cops". Analyzing such patterns can help to narrow down a speaker's identity, which is useful when validating, for example, whether it's still the same person behind an online avatar.

Now given a paragraph of text sampled from someone's speech, can you find the person's most commonly used word?

Input Specification:

Each input file contains one test case. For each case, there is one line of text no more than 1048576 characters in length, terminated by a carriage return \n. The input contains at least one alphanumerical character, i.e., one character from the set [0-9 A-Z a-z].

Output Specification:

For each test case, print in one line the most commonly occurring word in the input text, followed by a space and the number of times it has occurred in the input. If there are more than one such words, print the lexicographically smallest one. The word should be printed in all lower case. Here a "word" is defined as a continuous sequence of alphanumerical characters separated by non-alphanumerical characters or the line beginning/end.

Note that words are case insensitive.

Sample Input:

Can1: "Can a can can a can?  It can!"

Sample Output:

can 5

题⽬⼤意:统计单词个数~⼤⼩写字⺟+数字的组合才是合法的单词,给出⼀个字符串,求出现的合法

的单词的个数最多的那个单词,以及它出现的次数。如果有并列的,那么输出字典序⾥⾯的第⼀个~

分析:⽤map很简单的~不过呢~有⼏个注意点~:

1. ⼤⼩写不区分,所以统计之前要先s[i] = tolower(s[i]);

2. [0-9 A-Z a-z]可以简写为cctype头⽂件⾥⾯的⼀个函数isalnum~~

3. 必须⽤getline读⼊⼀⻓串的带空格的字符串~~

4. ⼀定要当t不为空的时候m[t]++,因为t为空也会被统计的!!!~~

5. 最重要的是~如果i已经到了最后⼀位,不管当前位是不是字⺟数字,都得将当前这个t放到map

⾥⾯(只要t⻓度不为0)~

 

#include <iostream>
#include <map>
#include <cctype>
using namespace std;
int main() {
    string s, t;
    getline(cin, s);
    map<string, int> m;
    for( int i = 0; i < s.length(); i++) {
         if( isalnum(s[i]) ) {
             s[i] = tolower(s[i]);
             t += s[i];
         }
         if( !isalnum(s[i]) || i == s.length() - 1 ){
             if( t.length() != 0) 
			     m[t]++; 
			 t = "";
         }
    }
    int maxn = 0;
    for( auto it = m.begin(); it != m.end(); it++) {
         if( it->second > maxn ) {
             t = it->first;
             maxn = it->second;
         }
     }
    cout << t << " " << maxn;
    return 0; 
}

 

上一篇:任何人都可以在C推荐一个像样的DSP /语音库吗?


下一篇:Leecode 914. 卡牌分组