问题 A: Speech Patterns (25)

题目描述
People often have a preference among synonyms of the same word. For example, some may prefer “the police”, while others may prefer “the cops”. Analyzing such patterns can help to narrow down a speaker’s identity, which is useful when validating, for example, whether it’s still the same person behind an online avatar.

Now given a paragraph of text sampled from someone’s speech, can you find the person’s most commonly used word?

输入
Each input file contains one test case. For each case, there is one line of text no more than 1048576 characters in length, terminated by a carriage return ‘\n’. The input contains at least one alphanumerical character, i.e., one character from the set [0-9 A-Z a-z].
输出
For each test case, print in one line the most commonly occurring word in the input text, followed by a space and the number of times it has occurred in the input. If there are more than one such words, print the lexicographically smallest one. The word should be printed in all lower case. Here a “word” is defined as a continuous sequence of alphanumerical characters separated by non-alphanumerical characters or the line beginning/end.

Note that words are case insensitive.

样例输入 Copy
Can1: “Can a can can a can? It can!”
样例输出 Copy
can 5

注意用getline读入。注意题目中对于单词的定义。

#include <iostream>
#include<bits/stdc++.h>
#include<string>
using namespace std;
string b,s;
int main()
{
    int i;
    string x;
    int Max=0;
    map<string,int>a;
    getline(cin,s);
    b="";
    for(i=0; i<s.size(); i++)
    {
        if(s[i]>='A'&&s[i]<='Z')
            s[i]=s[i]+32;
        if((s[i]>='0'&&s[i]<='9')||(s[i]>='a'&&s[i]<='z'))
            b.push_back(s[i]);
        else
        {
            if(b!="")
            {
                a[b]++;
                b="";
            }

        }
    }
    if(b!="")
    {
        a[b]++;
        b="";
    }
    for(map<string,int>::iterator it=a.begin(); it!=a.end(); it++)
    {
        if(it->second>Max)
        {
            Max=it->second;
            x=it->first;
        }
    }
    if(Max!=0)
        cout<<x<<" "<<Max<<endl;
    else cout<<0<<endl;
    return 0;
}

问题 A: Speech Patterns (25)问题 A: Speech Patterns (25) weixin_43886377 发布了294 篇原创文章 · 获赞 10 · 访问量 1万+ 私信 关注
上一篇:手机微信语音批量转文字 使用百度语音识别


下一篇:1071 Speech Patterns