1009 Product of Polynomials (25 分)

1009 Product of Polynomials (25 分)

This time, you are supposed to find A×B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ ... N​K​​ a​N​K​​​​

where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10, 0≤N​K​​<⋯<N​2​​<N​1​​≤1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 3 3.6 2 6.0 1 1.6

【分析】多项式相乘

总结:

1. map在遍历时不可以加入新的映射!

2. pair 用起来很方便

#include <iostream>
#include <cstdio>
#include <map>
using namespace std;
const int maxn = 105;
int k, n;
double coe;
typedef pair<int, double> P;
P poly1[maxn], poly2[maxn];
map<int, double> poly;
int main() {
    cin >> k;
    for (int i = 0; i < k; i++) {
        scanf("%d %lf", &poly1[i].first, &poly1[i].second);
    }
    cin >> k;
    for (int i = 0; i < k; i++) {
        scanf("%d %lf", &poly2[i].first, &poly2[i].second);
    }
    for (int i = 0; i < k; i++) {
        for (int j = 0; j < k; j++) {
            int t = poly1[i].first + poly2[j].first;
            double c = poly1[i].second * poly2[j].second;
            poly[t] += c;
            if (poly[t] == 0) {
                map<int, double>::iterator it = poly.find(t);
                poly.erase(it);
            }
        }
    }
    if (poly.size() > 0) printf("%d", poly.size());
    else {
        printf("0");
        return 0;
    }
    for (map<int, double>::reverse_iterator it = poly.rbegin(); it != poly.rend(); it++) {
        printf(" %d %.1f", it->first, it->second);
    }
    return 0;
}

 

上一篇:译文:如何让Low Poly好看


下一篇:斯特林数学习笔记