POJ_2318_TOYS&&POJ_2398_Toy Storage_二分+判断直线和点的位置关系

POJ_2318_TOYS&&POJ_2398_Toy Storage_二分+判断直线和点的位置

Description

Calculate the number of toys that land in each bin of a partitioned toy box.
Mom and dad have a problem - their child John never puts his toys
away when he is finished playing with them. They gave John a rectangular
box to put his toys in, but John is rebellious and obeys his parents by
simply throwing his toys into the box. All the toys get mixed up, and
it is impossible for John to find his favorite toys.

John's parents came up with the following idea. They put cardboard
partitions into the box. Even if John keeps throwing his toys into the
box, at least toys that get thrown into different bins stay separated.
The following diagram shows a top view of an example toy box.

POJ_2318_TOYS&&POJ_2398_Toy Storage_二分+判断直线和点的位置关系

For this problem, you are asked to determine how many toys fall into each partition as John throws them into the toy box.

Input

The
input file contains one or more problems. The first line of a problem
consists of six integers, n m x1 y1 x2 y2. The number of cardboard
partitions is n (0 < n <= 5000) and the number of toys is m (0
< m <= 5000). The coordinates of the upper-left corner and the
lower-right corner of the box are (x1,y1) and (x2,y2), respectively. The
following n lines contain two integers per line, Ui Li, indicating that
the ends of the i-th cardboard partition is at the coordinates (Ui,y1)
and (Li,y2). You may assume that the cardboard partitions do not
intersect each other and that they are specified in sorted order from
left to right. The next m lines contain two integers per line, Xj Yj
specifying where the j-th toy has landed in the box. The order of the
toy locations is random. You may assume that no toy will land exactly on
a cardboard partition or outside the boundary of the box. The input is
terminated by a line consisting of a single 0.

Output

The
output for each problem will be one line for each separate bin in the
toy box. For each bin, print its bin number, followed by a colon and one
space, followed by the number of toys thrown into that bin. Bins are
numbered from 0 (the leftmost bin) to n (the rightmost bin). Separate
the output of different problems by a single blank line.

Sample Input

5 6 0 10 60 0
3 1
4 3
6 8
10 10
15 30
1 5
2 1
2 8
5 5
40 10
7 9
4 10 0 10 100 0
20 20
40 40
60 60
80 80
5 10
15 10
25 10
35 10
45 10
55 10
65 10
75 10
85 10
95 10
0

Sample Output

0: 2
1: 1
2: 1
3: 1
4: 0
5: 1 0: 2
1: 2
2: 2
3: 2
4: 2

2318:对于每个玩具,二分查找一下,判断这个点在直线的左边还是右边,判断叉积的正负即可。
2398:同理,只需要对点排个序。 代码(2318):
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
typedef double f2;
#define N 5050
#define eps 1e-6
int n,m,x_1,x_2,y_1,y_2,x_t,y_t;
int u[N],l[N],L,R,ans[N];
struct Point {
f2 x,y;
Point() {}
Point(f2 x_,f2 y_) :
x(x_),y(y_) {}
Point operator + (const Point &p) {return Point(x+p.x,y+p.y);}
Point operator - (const Point &p) {return Point(x-p.x,y-p.y);}
Point operator * (f2 rate) {return Point(x*rate,y*rate);}
};
f2 dot(const Point &p1,const Point &p2) {return p1.x*p2.x+p1.y*p2.y;}
f2 cross(const Point &p1,const Point &p2) {return p1.x*p2.y-p1.y*p2.x;}
bool check(int x) {
Point A=Point(u[x]-l[x],y_1-y_2);
Point B=Point(u[x]-x_t,y_1-y_t);
return cross(B,A)>-eps;
}
void init() {
memset(ans,0,sizeof(ans));
}
int main() {
while(1) {
scanf("%d",&n);
if(!n) return 0;
init();
scanf("%d%d%d%d%d",&m,&x_1,&y_1,&x_2,&y_2);
u[0]=0; l[0]=0;
int i;
for(i=1;i<=n;i++) {
scanf("%d%d",&u[i],&l[i]);
}
for(i=1;i<=m;i++) {
scanf("%d%d",&x_t,&y_t);
L=0; R=n+1;
while(L<R) {
int mid=(L+R)>>1;
if(check(mid)) R=mid;
else L=mid+1;
}
ans[L-1]++;
}
for(i=0;i<=n;i++) {
printf("%d: %d\n",i,ans[i]);
}
puts("");
}
}

代码(2318):

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
typedef double f2;
#define N 5050
#define eps 1e-6
int n,m,x_1,x_2,y_1,y_2,x_t,y_t;
int u[N],l[N],L,R,ans[N],cnt[N];
struct Point {
f2 x,y;
Point() {}
Point(f2 x_,f2 y_) :
x(x_),y(y_) {}
Point operator + (const Point &p) {return Point(x+p.x,y+p.y);}
Point operator - (const Point &p) {return Point(x-p.x,y-p.y);}
Point operator * (f2 rate) {return Point(x*rate,y*rate);}
};
f2 dot(const Point &p1,const Point &p2) {return p1.x*p2.x+p1.y*p2.y;}
f2 cross(const Point &p1,const Point &p2) {return p1.x*p2.y-p1.y*p2.x;}
bool check(int x) {
Point A=Point(u[x]-l[x],y_1-y_2);
Point B=Point(u[x]-x_t,y_1-y_t);
return cross(B,A)>-eps;
}
void init() {
memset(ans,0,sizeof(ans));
memset(cnt,0,sizeof(cnt));
}
int main() {
while(1) {
scanf("%d",&n);
if(!n) return 0;
init();
scanf("%d%d%d%d%d",&m,&x_1,&y_1,&x_2,&y_2);
u[0]=0; l[0]=0;
int i;
for(i=1;i<=n;i++) {
scanf("%d%d",&u[i],&l[i]);
}
sort(u+1,u+n+1);
sort(l+1,l+n+1);
ans[0]=n+1;
for(i=1;i<=m;i++) {
scanf("%d%d",&x_t,&y_t);
L=0; R=n+1;
while(L<R) {
int mid=(L+R)>>1;
if(check(mid)) R=mid;
else L=mid+1;
}
ans[cnt[L-1]]--;
cnt[L-1]++;
ans[cnt[L-1]]++;
}
puts("Box");
for(i=1;i<=m;i++) {
if(ans[i])
printf("%d: %d\n",i,ans[i]);
}
}
}
上一篇:visio UML用例里面找不到include关系


下一篇:PHPCMS V9完全开发介绍