[PAT 甲级] 1016 Phone Bills (25 分)

1016 Phone Bills (25 分)

原题链接

A long-distance telephone company charges its customers by the following rules:

Making a long-distance call costs a certain amount per minute, depending on the time of day when the call is made. When a customer starts connecting a long-distance call, the time will be recorded, and so will be the time when the customer hangs up the phone. Every calendar month, a bill is sent to the customer for each minute called (at a rate determined by the time of day). Your job is to prepare the bills for each month, given a set of phone call records.

Input Specification:
Each input file contains one test case. Each case has two parts: the rate structure, and the phone call records.

The rate structure consists of a line with 24 non-negative integers denoting the toll (cents/minute) from 00:00 - 01:00, the toll from 01:00 - 02:00, and so on for each hour in the day.

The next line contains a positive number N (≤1000), followed by N lines of records. Each phone call record consists of the name of the customer (string of up to 20 characters without space), the time and date (mm:dd:hh:mm), and the word on-line or off-line.

For each test case, all dates will be within a single month. Each on-line record is paired with the chronologically next record for the same customer provided it is an off-line record. Any on-line records that are not paired with an off-line record are ignored, as are off-line records not paired with an on-line record. It is guaranteed that at least one call is well paired in the input. You may assume that no two records for the same customer have the same time. Times are recorded using a 24-hour clock.

Output Specification:
For each test case, you must print a phone bill for each customer.

Bills must be printed in alphabetical order of customers’ names. For each customer, first print in a line the name of the customer and the month of the bill in the format shown by the sample. Then for each time period of a call, print in one line the beginning and ending time and date (dd:hh:mm), the lasting time (in minute) and the charge of the call. The calls must be listed in chronological order. Finally, print the total charge for the month in the format shown by the sample.

Sample Input:
10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10
10
CYLL 01:01:06:01 on-line
CYLL 01:28:16:05 off-line
CYJJ 01:01:07:00 off-line
CYLL 01:01:08:03 off-line
CYJJ 01:01:05:59 on-line
aaa 01:01:01:03 on-line
aaa 01:02:00:01 on-line
CYLL 01:28:15:41 on-line
aaa 01:05:02:24 on-line
aaa 01:04:23:59 off-line
Sample Output:
CYJJ 01
01:05:59 01:07:00 61 $12.10
Total amount: $12.10
CYLL 01
01:06:01 01:08:03 122 $24.40
28:15:41 28:16:05 24 $3.85
Total amount: $28.25
aaa 01
02:00:01 04:23:59 4318 $638.80
Total amount: $638.80


这一题的关键在于如何分级计算资费,这里使用的方法是计算00:00:00 到 dd:hh:mm 的资费再相减。

double fun(node t) {
    double ans = toll[t.h] * t.m + tot * t.d;
    for (int i = 0; i < t.h; i++) {
        ans += toll[i] * 60;
    }
    return ans / 100;
}

关于本题的坑点,就是有可能这个人他没有消费(不需要打印),也就是说没有匹配成功一条消费记录,可是他题目明确说明了**It is guaranteed that at least one call is well paired in the input. ** 这pat非要自己打自己的脸。
这真的坑爹啊,这就让人很无语,思考了半天。而解决的方法就是在print之前先扫一遍消费记录即可。
[PAT 甲级] 1016 Phone Bills (25 分)


代码有点丑…

#include<iostream>
#include<map>
#include<vector>
#include<set>
#include<algorithm>
using namespace std;

struct node {
    int mm, d, h, m;
    bool status = false;
};
map<string, vector<node> > cp;
set<string> ord;
int toll[24];
int tot;
bool cmp (node a, node b) {
    if (a.d == b.d) {
        if (a.h == b.h) {
            return a.m < b.m;
        } else {
            return a.h < b.h;
        }
    } else {
        return a.d < b.d;
    }
}
double fun(node t) {
    double ans = toll[t.h] * t.m + tot * t.d;
    for (int i = 0; i < t.h; i++) {
        ans += toll[i] * 60;
    }
    return ans / 100;
}
void print(string name) {
    sort(cp[name].begin(), cp[name].end(), cmp);
    vector<node> tem = cp[name];
    int len = int(tem.size());
    int flag = 0;
    bool test = false;
    for (int i = 0; i < len; i++) {
        if (tem[i].status == false && test == true) {
            flag = 1;
            break;
        }
        test = tem[i].status;
    }
    if (flag == 0) {
        return;
    }
    node t1, t2;
    cout << name;
    printf(" %02d\n",tem[0].mm);
    bool is_on = false;
    double top_m = 0;
    int tt = 0;
    for (int i = 0; i < len; i++) {
        t2 = tem[i];
        if (t2.status == true) {
            is_on = true;
            t1 = t2;
        } else if (is_on == true){
            tt = (t2.d - t1.d) * 1440 + (t2.h - t1.h) * 60 + (t2.m - t1.m);
            double ans = fun(t2) - fun(t1);
            printf("%02d:%02d:%02d %02d:%02d:%02d %d $%.2f\n",t1.d,t1.h,t1.m,t2.d,t2.h,t2.m,tt,ans);
            top_m += ans;
            is_on = false;
        }
    }
    printf("Total amount: $%.2f\n",top_m);
}
int main () {
    for (int i = 0; i <= 23; i++) {
        cin >> toll[i];
        tot += toll[i] * 60;
    }
    int n;
    string name, status;
    cin >> n;
    while (n--) {
        cin >> name;
        ord.insert(name);
        node tem;
        scanf("%d:%d:%d:%d", &tem.mm, &tem.d, &tem.h, &tem.m);
        cin >> status;
        if (status == "on-line") {
            tem.status = true;
        } else {
            tem.status = false;
        }
        cp[name].push_back(tem);
    }
    set<string>::iterator it = ord.begin();
    for (;it != ord.end(); it++) {
        print(*it);
    }
    return 0;
}

上一篇:插入排序算法(java)


下一篇:题解 括号密码