CCPC A(模拟)

Secrete Master Plan

Time Limit: 3000/1000MS (Java/Others)     Memory Limit: 65535/65535KB (Java/Others)
 
 

Master Mind KongMing gave Fei Zhang a secrete master plan stashed in a pocket. The plan instructs how to deploy soldiers on the four corners of the city wall. Unfortunately, when Fei opened the pocket he found there are only four numbers written in dots on a piece of sheet. The numbers form a 2×2 matrix, but Fei didn't know the correct direction to hold the sheet. What a pity!

Given two secrete master plans. The first one is the master's original plan. The second one is the plan opened by Fei. As KongMing had many pockets to hand out, he might give Fei the wrong pocket. Determine if Fei receives the right pocket.

CCPC A(模拟)

Input

The first line of the input gives the number of test cases, T(1≤T≤104). T test cases follow. Each test case contains 4 lines. Each line contains two integers ai0 and ai1 (1≤ai0,ai1≤100). The first two lines stands for the original plan, the 3rd and 4th line stands for the plan Fei opened.

Output

For each test case, output one line containing Case #x: y, where x is the test case number (starting from 1) and y is either "POSSIBLE" or "IMPOSSIBLE" (quotes for clarity).

Sample input and output

Sample Input Sample Output
4
1 2
3 4
1 2
3 4 1 2
3 4
3 1
4 2 1 2
3 4
3 2
4 1 1 2
3 4
4 3
2 1
Case #1: POSSIBLE
Case #2: POSSIBLE
Case #3: IMPOSSIBLE

题解:要善于把复杂问题简单化,而不是复杂化,自己用数组模拟了半天,好神经;

代码:

 #include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
const int INF=0x3f3f3f3f;
int main(){
int a,b,c,d,x,y,z,w;
int T,cnt=;
scanf("%d",&T);
while(T--){
scanf("%d%d%d%d",&b,&a,&c,&d);
scanf("%d%d%d%d",&y,&x,&z,&w);
bool t1=(a==x&&b==y&&c==z&&d==w);
bool t2=(a==y&&b==z&&c==w&&d==x);
bool t3=(a==z&&b==w&&c==x&&d==y);
bool t4=(a==w&&b==x&&c==y&&d==z);
int flot=;
if(t1||t2||t3||t4)flot=;
printf("Case #%d: ",++cnt);
if(flot)puts("POSSIBLE");
else puts("IMPOSSIBLE");
}
return ;
}
上一篇:MySQL多表数据记录查询详解


下一篇:python-unexpected content storage modification出错