怒刷DP之 HDU 1029

Ignatius and the Princess IV

Time Limit:1000MS     Memory Limit:32767KB     64bit IO Format:%I64d & %I64u

Appoint description: 
jehad  (2014-05-27)
gscsdlz  (2015-04-14)
System Crawler  (2015-09-05)

Description

"OK, you are not too bad, em... But you can never pass the next test." feng5166 says.

"I will tell you an odd number N, and then N integers. There will be a special integer among them, you have to tell me which integer is the special one after I tell you all the integers." feng5166 says.

"But what is the characteristic of the special integer?" Ignatius asks.

"The integer will appear at least (N+1)/2 times. If you can't find the right integer, I will kill the Princess, and you will be my dinner, too. Hahahaha....." feng5166 says.

Can you find the special integer for Ignatius?

 

Input

The input contains several test cases. Each test case contains two lines. The first line consists of an odd integer N(1<=N<=999999) which indicate the number of the integers feng5166 will tell our hero. The second line contains the N integers. The input is terminated by the end of file. 
 

Output

For each test case, you have to output only one line which contains the special number you have found. 
 

Sample Input

5
1 3 2 3 3
11
1 1 1 1 1 5 5 5 5 5 5
7
1 1 1 1 1 1 1
 

Sample Output

3
5
1
 
 #include <iostream>
#include <cstdio>
#include <string>
#include <queue>
#include <vector>
#include <map>
#include <algorithm>
#include <cstring>
#include <cctype>
#include <cstdlib>
#include <cmath>
#include <ctime>
#include <climits>
using namespace std; int main(void)
{
int n,box,count,max; while(scanf("%d",&n) != EOF)
{
count = ;
while(n --)
{
scanf("%d",&box); if(!count)
{
max = box;
count ++;
}
else
if(max == box)
count ++;
else
count --;
}
printf("%d\n",max);
} return ;
}
上一篇:openerp 经典收藏 记录规则 – 销售只能看到自己的客户,经理可以看到全部(转载)


下一篇:在fragment中获取他附着的activity中的变量