佐助被大蛇丸诱骗走了,鸣人在多少时间内能追上他呢?
已知一张地图(以二维矩阵的形式表示)以及佐助和鸣人的位置。地图上的每个位置都可以走到,只不过有些位置上有大蛇丸的手下,需要先打败大蛇丸的手下才能到这些位置。鸣人有一定数量的查克拉,每一个单位的查克拉可以打败一个大蛇丸的手下。假设鸣人可以往上下左右四个方向移动,每移动一个距离需要花费1个单位时间,打败大蛇丸的手下不需要时间。如果鸣人查克拉消耗完了,则只可以走到没有大蛇丸手下的位置,不可以再移动到有大蛇丸手下的位置。佐助在此期间不移动,大蛇丸的手下也不移动。请问,鸣人要追上佐助最少需要花费多少时间?
Input
输入的第一行包含三个整数:M,N,T。代表M行N列的地图和鸣人初始的查克拉数量T。0 < M,N < 200,0 ≤ T < 10
后面是M行N列的地图,其中@代表鸣人,+代表佐助。*代表通路,#代表大蛇丸的手下。
Output
输入的第一行包含三个整数:M,N,T。代表M行N列的地图和鸣人初始的查克拉数量T。0 < M,N < 200,0 ≤ T < 10
后面是M行N列的地图,其中@代表鸣人,+代表佐助。*代表通路,#代表大蛇丸的手下。
样例输入1 4 4 1 #@## **## ###+ ****
样例输出1 6
样例输入2 4 4 2 #@## **## ###+ ****
样例输出2 4
简单bfs。
同一位置不同能量也记为一种情况,故需开三维数组来标记路径。
#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
char f[210][210];
int vis[210][210][15];
int dp[4][2]={0,1,1,0,-1,0,0,-1};
int m,n,t;
struct ss
{
int x,y;
int step;
int e;
};
void bfs(int q,int w)
{
queue<ss>p;
ss now,nex;
now.x=q;
now.y=w;
now.e=t;
now.step=0;
p.push(now);
while(!p.empty())
{
now=p.front();
p.pop();
if(f[now.x][now.y]=='+')
{
cout<<now.step<<endl;
return;
}
for(int i=0;i<4;i++)
{
int tx=now.x+dp[i][0];
int ty=now.y+dp[i][1];
if(tx<0||ty<0||tx>=m||ty>=n)
continue;
if(f[tx][ty]=='#')
{
if(now.e>0&&!vis[tx][ty][now.e-1])
{
nex.e=now.e-1;
vis[tx][ty][nex.e]=1;
nex.x=tx;
nex.y=ty;
nex.step=now.step+1;
p.push(nex);
}
else
continue;
}
else
{
if(vis[tx][ty][now.e]==1)
continue;
nex.e=now.e;
vis[tx][ty][nex.e]=1;
nex.x=tx;
nex.y=ty;
nex.step=now.step+1;
p.push(nex);
}
}
}
cout<<"-1"<<endl;
return ;
}
int main()
{
cin>>m>>n>>t;
int a,b;
getchar();
for(int i=0;i<m;i++)
for(int j=0;j<n;j++)
{
cin>>f[i][j];
if(f[i][j]=='@')
{
a=i;
b=j;
}
}
vis[a][b][t]=1;
bfs(a,b);
}