hdu 1021 Fibonacci Again(找规律)

http://acm.hdu.edu.cn/showproblem.php?pid=1021

Fibonacci Again

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 29201    Accepted Submission(s): 14148

Problem Description
There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).
 
Input
Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).
 
Output
Print the word "yes" if 3 divide evenly into F(n).
Print the word "no" if not.
 
Sample Input
0
1
2
3
4
5
 
Sample Output
no
no
yes
no
no
no
 
Author
Leojay
 
思路:
题意:以7 11 开始的类似斐波拉契数列中能被3整除的输出yes  否则输出no
不解释 怒找一规律
 
上代码:
 #include<iostream>
#include<stdio.h>
#include<string.h> using namespace std; int main()
{
int n;
while(~scanf("%d",&n))
{
if((n-)%==) puts("yes");
else puts("no");
}
return ;
}
 
上一篇:在mysql数据库原有字段后增加新内容


下一篇:一个简单的日志函数C++