PAT甲级1109 Group Photo (25 分)

1109 Group Photo (25 )

Formation is very important when taking a group photo. Given the rules of forming K rows with N people as the following:

  • The number of people in each row must be N/K (round down to the nearest integer), with all the extra people (if any) standing in the last row;
  • All the people in the rear row must be no shorter than anyone standing in the front rows;
  • In each row, the tallest one stands at the central position (which is defined to be the position (m/2+1), where m is the total number of people in that row, and the division result must be rounded down to the nearest integer);
  • In each row, other people must enter the row in non-increasing order of their heights, alternately taking their positions first to the right and then to the left of the tallest one (For example, given five people with their heights 190, 188, 186, 175, and 170, the final formation would be 175, 188, 190, 186, and 170. Here we assume that you are facing the group so your left-hand side is the right-hand side of the one at the central position.);
  • When there are many people having the same height, they must be ordered in alphabetical (increasing) order of their names, and it is guaranteed that there is no duplication of names.

Now given the information of a group of people, you are supposed to write a program to output their formation.

Input Specification:

Each input file contains one test case. For each test case, the first line contains two positive integers N (≤10​4​​), the total number of people, and K (≤10), the total number of rows. Then N lines follow, each gives the name of a person (no more than 8 English letters without space) and his/her height (an integer in [30, 300]).

Output Specification:

For each case, print the formation -- that is, print the names of people in K lines. The names must be separated by exactly one space, but there must be no extra space at the end of each line. Note: since you are facing the group, people in the rear rows must be printed above the people in the front rows.

Sample Input:

10 3

Tom 188

Mike 170

Eva 168

Tim 160

Joe 190

Ann 168

Bob 175

Nick 186

Amy 160

John 159

Sample Output:

Bob Tom Joe Nick

Ann Mike Eva

Tim Amy John

      题目大意:

         给出n个人的名字和身高以及要求排的行数k,要求进行排队拍照。共分为 n/ k行并且最后一行必须向上取整,如果n不能被整除的话。每一行最高的要排到中间(第row / 2 + 1个),次高的依次位于左边和右边,依次类推。前一排不能高于后一排。

 

思路:

         本质上是一个二维string数组,最下面的一行是最矮的,如果可以整除的话,那么每一行都是一样多人,否则出了数组第一行每一行都会少一些人,数组第一行一定是n/ k + n % k,含义是第一行也理应更其他行一样多人,只不过在不能被整除的情况下,余数都给数组第一行了,例如 11 个人排3行。

         身高排序让大家从高到矮的排好后从m / 2 + 1开始向两边填充。

         由于不是图形输出,(不用把整个数组存完再输出,例如前面的螺旋数组就需要),排好一行输出一行。

参考代码:

#include<iostream>
#include<vector>
#include<string>
#include<algorithm>
using namespace std;
struct node{
	string name;
	int h;
}; 
vector<node> list;
int n, k;
bool cmp(node a, node b){
	if(a.h != b.h) return a.h  > b.h;
	else	return a.name < b.name;
}
int main(){
	scanf("%d%d", &n, &k);
	list.resize(n);
	for(int i = 0; i < n; ++i)
		cin >> list[i].name >> list[i].h;
	int num = 0;
	sort(list.begin(), list.end(), cmp);
	for(int i = 0; i < k; ++i){
		int idx, mid;
		if(i == 0)	idx = n / k + n % k;
		else	idx = n / k;
		vector<string> ans(idx);
		mid = idx / 2;
		ans[mid] = list[num++].name;
		int l = mid - 1, r = mid + 1;
		while(l >= 0 || r < idx){
			if(l >= 0)	ans[l] = list[num++].name;
			if(r < idx) ans[r] = list[num++].name;
		 l--, r++;
		}
		printf("%s", ans[0].c_str());
		for(int i = 1; i < ans.size(); ++i)
			printf(" %s", ans[i].c_str());
		printf("\n");
	}
	return 0;
}

 

 

上一篇:在android和服务器中发布照片用例


下一篇:学图像处理技术,新秀Affinity Photo与Photoshop比哪家强?