描述
某百货公司仓库中有一批电视机,按其价格严格从低到高的次序,以链表(链表含头结点)的形式存储于计算机中,链表的每个结点表示同样价格的电视机台数。现在又有m台价格为x元的电视机准备入库,请将其加入到链表中(保证价格仍然严格从低到高)完成入库操作。
链表结点(Node类型)包含三个域,分别为价格、数量和指针域:
cost | num | next |
题目部分代码已经完成,您只需要补充并提交以下函数:
void Add(Node* head, int m, int x);//其中head为链表头指针,m和x见题意
输入
输入数据的第一行为原始链表中结点的数目n。
接下来有n行,每行为2个正整数mi和xi,表示链表中各个结点的电视机台数和价格,其中x1<x2<x3<...<xn。
下一行有两个正整数m和x,表示待入库的电视机台数和价格。
输出
输出插入完成后,从头到尾遍历链表并输出电视的台数和价格,每行一个结点。
样例输入
3
1 1000
3 2000
2 3000
10 2100
样例输出
1 1000
3 2000
10 2100
2 3000
#include <bits/stdc++.h>
using namespace std;
struct Node
{
int num,money;
Node *next;
};
void Printff(Node *head)
{
Node *e=head->next;
while(e)
{
cout << e->num << " " << e->money << endl;
e=e->next;
}
}
void Add(Node* head, int m, int x)
{
Node *e=head->next; //e为第一个节点
if(x<e->cost) //特判最小
{
Node *q=(Node*)malloc(sizeof(Node));
q->num=m,q->cost=x;
q->next=head->next;
head->next=q;
return;
}
while(x>e->cost)
{
e=e->next;
if(e==NULL)
break;
}
if(e==NULL) //没有找到
{
Node *p=head->next;
while(p->next!=NULL)
{
p=p->next;
}
Node *q=(Node*)malloc(sizeof(Node));
q->num=m,q->cost=x,q->next=NULL;
p->next=q;
}
else //在链表里面找打比他大的money
{
if(e->cost==x)
{
e->num+=m;
}
else if(e->cost>x)
{
Node *p=head->next;
while(p->next->cost<x&&p->next!=NULL)
{
p=p->next;
} //找到他的上一个节点
Node *t=(Node*)malloc(sizeof(Node));
t->num=m,t->cost=x;
t->next=p->next;
p->next=t;
}
}
}
Node *Creat()
{
int n,d1,d2;
Node *head,*rear;
head=new Node,head->next=NULL,rear=head;
cin>>n;
while(n--)
{
cin>>d1>>d2;
Node *e=new Node;
e->num=d1,e->money=d2,e->next=NULL;
rear->next=e;
rear=e;
} return head;
}
int main()
{
Node *head;
head=Creat();
int m,x;
cin>>m>>x;
Add(head,m,x);
Printff(head);
}