还是畅通工程
from hdu 1233
Time Limit: 4000/2000 MS (Java/Others)
Memory Limit: 65536/32768 K (Java/Others)
Problem Description:
某省调查乡村交通状况,得到的统计表中列出了任意两村庄间的距离。省*“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可),并要求铺设的公路总长度为最小。请计算最小的公路总长度。
Input:
测试输入包含若干测试用例。每个测试用例的第1行给出村庄数目N ( < 100 );随后的N(N-1)/2行对应村庄间的距离,每行给出一对正整数,分别是两个村庄的编号,以及此两村庄间的距离。为简单起见,村庄从1到N编号。
当N为0时,输入结束,该用例不被处理。
Output:
对每个测试用例,在1行里输出最小的公路总长度。
Sample Input:
3
1 2 1
1 3 2
2 3 4
4
1 2 1
1 3 4
1 4 1
2 3 3
2 4 2
3 4 5
0
Sample Output:
3
5
Hint:
Huge input, scanf is recommended.
#include<iostream>
#include<queue>
using namespace std;
int father[105];
struct Node {
int f;
int t;
int w; //每条边的两个顶点f,t,权重w
};
Node a;
struct cmp1 {
bool operator() (Node a, Node b) {
return a.w > b.w; //自定义的缺陷队列比较规则
}
};
int n;
int find(int x) {
if (father[x] == x)
return x;
return father[x] = find(father[x]);
} //查找父亲
int main() {
while (scanf("%d", &n) && n) {
int sum = 0;
priority_queue<Node, vector<Node>, cmp1> qq; //优先队列,让边权小的先被访问
for (int i = 1; i <= n; ++i)
father[i] = i; //初始化,让每个点的父亲都是自己
for (int i = 1, j = n * (n - 1) / 2; i <= j; ++i) {
scanf("%d %d %d", &a.f, &a.t, &a.w);
qq.push(a);
}
for (int i = 1, j = n * (n - 1) / 2; i <= j; ++i) {
a = qq.top(); qq.pop();
int x = find(a.f), y = find(a.t);
if (x != y) { //如果被访问的边的两个端点的父亲不是相同的,则这条边会在目标最小生成树树中
sum += a.w;
father[x] = y;
}
}
printf("%d\n", sum);
}
return 0;
}