Hdu2952 Counting Sheep 2017-01-18 14:56 44人阅读 评论(0) 收藏

Counting Sheep

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 38   Accepted Submission(s) : 27

Font: Times New Roman | Verdana | Georgia

Font Size: ← →

Problem Description

A while ago I had trouble sleeping. I used to lie awake, staring at the ceiling, for hours and hours. Then one day my grandmother suggested I tried counting sheep after I'd gone to bed. As always when my grandmother suggests things, I decided to try it out.
The only problem was, there were no sheep around to be counted when I went to bed.

Hdu2952 Counting Sheep                                                                                            2017-01-18 14:56             44人阅读              评论(0)              收藏




Creative as I am, that wasn't going to stop me. I sat down and wrote a computer program that made a grid of characters, where # represents a sheep, while . is grass (or whatever you like, just not sheep). To make the counting a little more interesting, I also
decided I wanted to count flocks of sheep instead of single sheep. Two sheep are in the same flock if they share a common side (up, down, right or left). Also, if sheep A is in the same flock as sheep B, and sheep B is in the same flock as sheep C, then sheeps
A and C are in the same flock.





Now, I've got a new problem. Though counting these sheep actually helps me fall asleep, I find that it is extremely boring. To solve this, I've decided I need another computer program that does the counting for me. Then I'll be able to just start both these
programs before I go to bed, and I'll sleep tight until the morning without any disturbances. I need you to write this program for me.

Input

The first line of input contains a single number T, the number of test cases to follow.



Each test case begins with a line containing two numbers, H and W, the height and width of the sheep grid. Then follows H lines, each containing W characters (either # or .), describing that part of the grid.

Output

For each test case, output a line containing a single number, the amount of sheep flock son that grid according to the rules stated in the problem description.



Notes and Constraints

0 < T <= 100

0 < H,W <= 100

Sample Input

2
4 4
#.#.
.#.#
#.##
.#.#
3 5
###.#
..#..
#.###

Sample Output

6
3

Source

IDI Open 2009



———————————————————————————————————————————————————
求#的连通块的数量,直接dfs


#include<iostream>
#include<cmath>
using namespace std;
char map[105][105];
int m, n, t;
int dir[4][2] = { { -1, 0 },{ 0, -1 }, { 0, 1 },{ 1, 0 } }; void dfs(int si, int sj)
{
    if (si <= 0 || sj <= 0 || si > m || sj > n)
        return;
    for (int i = 0; i < 4; i++)
    {
        if (map[si + dir[i][0]][sj + dir[i][1]] != '.')
        {
            map[si + dir[i][0]][sj + dir[i][1]] = '.';
            dfs(si + dir[i][0], sj + dir[i][1]);
        }
    }
    return;
}
int main()
{
    int o;
    while(~scanf("%d",&o))
    {
        while(o--)
        {
            cin >> m >> n;
            {
                for (int i = 1; i <= m;i++)
                    for (int j = 1; j <= n; j++)
                        cin >> map[i][j];
                t = 0;
                for (int i = 1; i <= m; i++)
                    for (int j = 1; j <= n; j++)
                    {
                        if (map[i][j] == '#')
                        {
                            map[i][j] = '.';
                            t++;
                            dfs(i, j);
                        }
                    }
                    printf("%d\n", t);
            }
        }
    }
        return 0;     }


上一篇:记一次centos7重启后docker无法启动的问题


下一篇:20+富有创意的BuddyPress网站