1030 完美数列 (25分)
给定一个正整数数列,和正整数 p,设这个数列中的最大值是 M,最小值是 m,如果 M≤mp,则称这个数列是完美数列。
现在给定参数 p 和一些正整数,请你从中选择尽可能多的数构成一个完美数列。
输入格式:
输入第一行给出两个正整数 N 和 p,其中 N(≤105)是输入的正整数的个数,p(≤109)是给定的参数。第二行给出 N 个正整数,每个数不超过 109。
输出格式:
在一行中输出最多可以选择多少个数可以用它们组成一个完美数列。
输入样例:
10 8
2 3 20 4 5 1 6 7 8 9
输出样例:
8
作者: CAO, Peng
单位: Google
时间限制: 200 ms
内存限制: 64 MB
代码长度限制: 16 KB
//
// main.cpp
// cppdemo
//
// Created by 亓官 on 2020/1/12.
// Copyright © 2020 亓官. All rights reserved.
//
#include <iostream>
#include <vector>
#include <iterator>
#include <algorithm>
using namespace std;
int main(int argc, const char * argv[]) {
int n,i,j;
double p,re,min,max;
max = 0;
re = 1;
cin>>n>>p;
double store[100010];
for(int i = 0; i < n; i++){
cin>>store[i];
}
sort(store,store+n);
for(i = 0;i < n;i++){
min = store[i];
for(j = max; j < n; j++){
if(store[j] > p*min)
break;
if(re < (j-i+1))
re = j-i+1;
}
max = j;
}
cout<<re;
return 0;
}
亓官劼
发布了81 篇原创文章 · 获赞 50 · 访问量 7147
私信
关注