【Problem Description】:
Calculate a+b and output the sum in standard format – that is,
the digits must be separated into groups of three by commas (unless there are
less than four digits).
【Input Specification】:
Each input file contains one test case. Each case contains a pair
of integers a and b where -10 6<a,b<10 6. The numbers are separated by a
space.
【Output Specification】:
For each test case, you should output the sum of a and b in one
line. The sum must be written in the standard format.
【Sample Input】:
-1000000 9
【Sample Output】:
-999,991
【解题思路】
利用stringstream将两数之和转化为字符串,反转字符串,新建一字符串并在符合条件的位置增加逗号,反转该字符串。
【C++代码】
#include <iostream>
#include <algorithm>
#include <sstream>
#include <cmath>
#include <string>
using namespace std;
int main() {
int a,b,c;
cin>>a>>b;
c=a+b;
if(c<0) {
cout<<"-";
c=abs(c);
}
stringstream ss;
ss<<c;
string str=ss.str();
reverse(str.begin(),str.end());
string ans="";
for(int i=0; i<str.size(); i++) {
if((i%3==0)&&(i!=0)) {
ans+=",";
ans+=str[i];
} else ans+=str[i];
}
reverse(ans.begin(),ans.end());
cout<<ans<<endl;
return 0;
}
【Java代码】
import java.util.Scanner;
public class Main {
public static void main(String[] args) {
Scanner scan = new Scanner(System.in);
int a = scan.nextInt();
int b = scan.nextInt();
scan.close();
System.out.printf("%,d",a+b);//由于是标准格式可以直接输出
}
}