Trung is bored with his mathematics homeworks. He takes a piece of chalk and starts writing a sequence
of consecutive integers starting with 1 to N (1 < N < 10000). After that, he counts the number of
times each digit (0 to 9) appears in the sequence. For example, with N = 13, the sequence is:
12345678910111213
In this sequence, 0 appears once, 1 appears 6 times, 2 appears 2 times, 3 appears 3 times, and each
digit from 4 to 9 appears once. After playing for a while, Trung gets bored again. He now wants to
write a program to do this for him. Your task is to help him with writing this program.
Input
The input file consists of several data sets. The first line of the input file contains the number of data
sets which is a positive integer and is not bigger than 20. The following lines describe the data sets.
For each test case, there is one single line containing the number N.
Output
For each test case, write sequentially in one line the number of digit 0, 1, . . . 9 separated by a space.
Sample Input
2
3
13
Sample Output
0 1 1 1 0 0 0 0 0 0
1 6 2 2 1 1 1 1 1 1
题意概括:
把前n(n<=10000)个整数顺次写在一起:12345678910111213…数一数0-9各出现多少次(输出为10个整数,分别是0,1,2,3…9)的出现次数。
#include <iostream>
#include <string>
#include <cstring>
#include <cstdio> //sprintf()函数的使用
using namespace std;
int main()
{
int n;
cin>>n;
while(n--)
{
int a;
int ans[10];
memset(ans,0,sizeof(ans));
cin>>a;
string s="";
char p[10001];
for(int i=1;i<=a;i++)
{
sprintf(p,"%d",i); //c++禁止使用itoa函数
s=s+p;
}
int len=s.length();
for(int i=0;i<len;i++)
{
if(s[i]=='0') ans[0]++;
else if(s[i]=='1') ans[1]++;
else if(s[i]=='2') ans[2]++;
else if(s[i]=='3') ans[3]++;
else if(s[i]=='4') ans[4]++;
else if(s[i]=='5') ans[5]++;
else if(s[i]=='6') ans[6]++;
else if(s[i]=='7') ans[7]++;
else if(s[i]=='8') ans[8]++;
else if(s[i]=='9') ans[9]++;
}
for(int i=0;i<10;i++)
{
if(i==0) cout<<ans[i];
else cout<<" "<<ans[i];
}
cout<<endl;
}
return 0;
}