Basic Level 1044 火星数字 (20分)

题目

火星人是以 13 进制计数的:

地球人的 0 被火星人称为 tret。
地球人数字 1 到 12 的火星文分别为:jan, feb, mar, apr, may, jun, jly, aug, sep, oct, nov, dec。
火星人将进位以后的 12 个高位数字分别称为:tam, hel, maa, huh, tou, kes, hei, elo, syy, lok, mer, jou。
例如地球人的数字 29 翻译成火星文就是 hel mar;而火星文 elo nov 对应地球数字 115。为了方便交流,请你编写程序实现地球和火星数字之间的互译。

输入格式:

输入第一行给出一个正整数 N(<100),随后 N 行,每行给出一个 [0, 169) 区间内的数字 —— 或者是地球文,或者是火星文。

输出格式:

对应输入的每一行,在一行中输出翻译后的另一种语言的数字。

输入样例:

4
29
5
elo nov
tam

输出样例:

hel mar
may
115
13

思路分析:

代码:

#include <bits/stdc++.h>
using namespace std;

string earth[] = {"tret", "jan", "feb", "mar", "apr", "may", "jun", "jly", "aug", "sep", "oct", "nov", "dec"};
string spark[] = {" ", "tam", "hel", "maa", "huh", "tou", "kes", "hei", "elo", "syy", "lok", "mer", "jou"};
string s;
int len_s;

void earth2spark(int a){
    if(a / 13){
        cout << spark[a / 13];
    }
    if(a / 13 && a % 13){
        cout << " ";
    }
    if(a % 13 || a == 0){
        cout << earth[a % 13];
    }
}

void spark2earth(){
    int temp_1 = 0, temp_2 = 0;
    string s1, s2;
    if(len_s == 4){
        s1 = s.substr(0, 4);
    }else if(len_s > 4){
        s1 = s.substr(0, 3);
        s2 = s.substr(4);
    }else{
        s1 = s.substr(0, 3);
    }
    for(int i = 1; i < 13; i++){
        if(s1 == earth[i] || s2 == earth[i]){
            temp_2 = i;
        }
        if(s1 == spark[i]){
            temp_1 = i;
        }
    }
    cout << temp_1 * 13 + temp_2;
}

int main(){
    int n;
    cin >> n;
    getchar();
    for(int i = 0; i < n; i++){
        getline(cin, s);
        len_s = s.length();
        if(s[0] >= '0' && s[0] <= '9'){
            earth2spark(stoi(s));
        }else{
            spark2earth();
        }
        cout << endl;
    }
    return 0;
}

PAT_BasicLevel

上一篇:linux就该这么学 2021-01-08


下一篇:Oracle基础操作