Shopping
*Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8470 Accepted Submission(s): 3020
*
Problem Description
Every girl likes shopping,so does dandelion.Now she finds the shop is increasing the price every day because the Spring Festival is coming .She is fond of a shop which is called “memory”. Now she wants to know the rank of this shop’s price after the change of everyday.
Input
One line contians a number n ( n<=10000),stands for the number of shops.
Then n lines ,each line contains a string (the length is short than 31 and only contains lowercase letters and capital letters.)stands for the name of the shop.
Then a line contians a number m (1<=m<=50),stands for the days .
Then m parts , every parts contians n lines , each line contians a number s and a string p ,stands for this day ,the shop p 's price has increased s.
Output
Contains m lines ,In the ith line print a number of the shop “memory” ‘s rank after the ith day. We define the rank as :If there are t shops’ price is higher than the “memory” , than its rank is t+1.
Sample Input
3
memory
kfc
wind
2
49 memory
49 kfc
48 wind
80 kfc
85 wind
83 memory
Sample Output
1
2
题解
用map记录每个商店的价格
每天都遍历一遍,找出比memory价格高的商店的数量
#include <iostream>
#include <map>
#include <set>
using namespace std;
int main()
{
int N, M;
while (cin >> N)
{
map<string, int> rank;
string s;
for (int i = 1; i <= N; i++)
cin >> s;
cin >> M;
int x;
while (M--)
{
for (int i = 1; i <= N; i++)
{
cin >> x >> s;
rank[s] += x;
}
int i = 1;
for (auto e : rank)
if (e.second > rank["memory"])
i++;
cout << i << endl;
}
}
return 0;
}