题目 1559: 蓝桥杯算法提高VIP-解二元一次方程组

题目描述

给定一个二元一次方程组,形如:
a  *  x  +  b  *  y  =  c;
d  *  x  +  e  *  y  =  f;
x,y代表未知数,a,  b,  c,  d,  e,  f为参数。
求解x,y

输入

输入包含六个整数:  a,  b,  c,  d,  e,  f; 

数据规模和约定
0  < =  a,  b,  c,  d,  e,  f  < =  2147483647

输出

输出为方程组的解,两个整数x,  y。 

样例输入

3 7 41 2 1 9

样例输出

2 5
package parctice;

import java.util.Scanner;
public class ph1559 {
	public static void main(String[] args) {
		Scanner sc=new Scanner(System.in);
		int x,y;
		int a = sc.nextInt();
		int b = sc.nextInt();
		int c = sc.nextInt();
		int d = sc.nextInt();
		int e = sc.nextInt();
		int f = sc.nextInt();
		// 联立先求y,再把y值带回第一条式子求得x
		 y=((a*f)-(d*c))/((a*e)-d*b);
		 x=(c-b*y)/a;
		 System.out.println(x+" "+y);	
	}
}

 

上一篇:负载均衡模型


下一篇:企查查和天眼查哪个好用