1058 A+B in Hogwarts (20 分)

1058 A+B in Hogwarts (20 分)

If you are a fan of Harry Potter, you would know the world of magic has its own currency system -- as Hagrid explained it to Harry, "Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it's easy enough." Your job is to write a program to compute A+B where A and B are given in the standard form of Galleon.Sickle.Knut(Galleon is an integer in [0,10​7​​], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).

Input Specification:

Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input.

Sample Input:

3.2.1 10.16.27

Sample Output:

14.1.28

分析:水题,注意可能溢出,用long long保险点
 /**
 * Copyright(c)
 * All rights reserved.
 * Author : Mered1th
 * Date : 2019-02-24-01.29.25
 * Description : A1058
 */
 #include<cstdio>
 #include<cstring>
 #include<iostream>
 #include<cmath>
 #include<algorithm>
 #include<string>
 #include<unordered_set>
 #include<map>
 #include<vector>
 #include<set>
 using namespace std;

 int main(){
 #ifdef ONLINE_JUDGE
 #else
     freopen("1.txt", "r", stdin);
 #endif
     int b,c;
     int e,f;
     ,i=;
     ;
     scanf("%lld.%d.%d %lld.%d.%d",&a,&b,&c,&d,&e,&f);
     i=f+c;
     ){
         i-=;
         h++;
     }
     h=h+b+e;
     ){
         h-=;
         g++;
     }
     g=g+a+d;
     printf("%lld.%d.%d",g,h,i);
     ;
 }


上一篇:zabbix 四张大表分区


下一篇:UVA - 10048 Audiophobia Floyd