BZOJ 1621: [Usaco2008 Open]Roads Around The Farm分岔路口


题目


1621: [Usaco2008 Open]Roads Around The Farm分岔路口

Time Limit: 5 Sec  Memory Limit: 64 MB

Submit: 561  Solved: 407

[Submit][Status]

Description

    约翰的N(1≤N≤1,000,000,000)只奶牛要出发去探索牧场四周的土地.她们将沿着一条路走,一直走到三岔路口(可以认为所有的路口都是这样的).这时候,这一群奶牛可能会分成两群,分别沿着接下来的两条路继续走.如果她们再次走到三岔路口,那么仍有可能继续分裂成两群继续走.    奶牛的分裂方式十分古怪:如果这一群奶牛可以精确地分成两部分,这两部分的牛数恰好相差K(1≤K≤1000),那么在三岔路口牛群就会分裂.否则,牛群不会分裂,她们都将在这里待下去,平静地吃草.    请计算,最终将会有多少群奶牛在平静地吃草.

Input

两个整数N和K.

Output

最后的牛群数.

Sample Input

6 2



INPUT DETAILS:



There are 6 cows and the difference in group sizes is 2.


Sample Output

3



OUTPUT DETAILS:



There are 3 final groups (with 2, 1, and 3 cows in them).



6

/ \

2 4

/ \

1 3

HINT

6只奶牛先分成2只和4只.4只奶牛又分成1只和3只.最后有三群奶牛.


题解


直接模拟就行了,一旦奶牛数不足k+2或者奶牛数无法被分成x,x+k时中止。


代码

/*Author:WNJXYK*/
#include<cstdio>
#include<iostream>
#include<cstring>
#include<string>
#include<algorithm>
#include<queue>
#include<set>
#include<map>
using namespace std; #define LL long long
#define Inf 2147483647
#define InfL 10000000000LL inline void swap(int &x,int &y){int tmp=x;x=y;y=tmp;}
inline void swap(LL &x,LL &y){LL tmp=x;x=y;y=tmp;}
inline int remin(int a,int b){if (a<b) return a;return b;}
inline int remax(int a,int b){if (a>b) return a;return b;}
inline LL remin(LL a,LL b){if (a<b) return a;return b;}
inline LL remax(LL a,LL b){if (a>b) return a;return b;} int n,k; int solve(int x){
if (x<k+2 || (x+k)%2==1) return 1;
return solve((x+k)/2)+solve((x-k)/2);
}
int main(){
scanf("%d%d",&n,&k);
printf("%d\n",solve(n));
return 0;
}
上一篇:关于SQL 数据表中的密码加密


下一篇:(05) SpringBoot开发RESTFull?