我在桑拿大学603奇妙经历 C - Biorhythms

我在桑拿大学603奇妙经历 C - Biorhythms

题目

C - Biorhythms
Some people believe that there are three cycles in a person's life that start the day he or she is born. These three cycles are the physical, emotional, and intellectual cycles, and they have periods of lengths 23, 28, and 33 days, respectively. There is one peak in each period of a cycle. At the peak of a cycle, a person performs at his or her best in the corresponding field (physical, emotional or mental). For example, if it is the mental curve, thought processes will be sharper and concentration will be easier.
Since the three cycles have different periods, the peaks of the three cycles generally occur at different times. We would like to determine when a triple peak occurs (the peaks of all three cycles occur in the same day) for any person. For each cycle, you will be given the number of days from the beginning of the current year at which one of its peaks (not necessarily the first) occurs. You will also be given a date expressed as the number of days from the beginning of the current year. You task is to determine the number of days from the given date to the next triple peak. The given date is not counted. For example, if the given date is 10 and the next triple peak occurs on day 12, the answer is 2, not 3. If a triple peak occurs on the given date, you should give the number of days to the next occurrence of a triple peak.
Input
You will be given a number of cases. The input for each case consists of one line of four integers p, e, i, and d. The values p, e, and i are the number of days from the beginning of the current year at which the physical, emotional, and intellectual cycles peak, respectively. The value d is the given date and may be smaller than any of p, e, or i. All values are non-negative and at most 365, and you may assume that a triple peak will occur within 21252 days of the given date. The end of input is indicated by a line in which p = e = i = d = -1.
Output
For each test case, print the case number followed by a message indicating the number of days to the next triple peak, in the form:

Case 1: the next triple peak occurs in 1234 days.

Use the plural form ``days'' even if the answer is 1.
Sample Input
0 0 0 0
0 0 0 100
5 20 34 325
4 5 6 7
283 102 23 320
203 301 203 40
-1 -1 -1 -1
Sample Output
Case 1: the next triple peak occurs in 21252 days.
Case 2: the next triple peak occurs in 21152 days.
Case 3: the next triple peak occurs in 19575 days.
Case 4: the next triple peak occurs in 16994 days.
Case 5: the next triple peak occurs in 8910 days.
Case 6: the next triple peak occurs in 10789 days.

思路

英文 阿巴阿巴

翻译(有道yyds)

你会遇到很多情况。每种情况的输入由一行4个整数p、e、i和d组成。p、e和i的值分别是从今年年初开始物理、情感和智力周期达到峰值的天数。值d是给定的日期,可以小于p、e或i中的任何一个。所有的值都是非负的,最多365,你可以假设一个三重峰值将在给定日期的21252天内出现。输入的结束由一行表示,其中p = e = i = d = -1。

对于每个测试用例,以如下形式打印用例号,后面跟着指示到下一个三峰的天数的消息:

案例1:下一个三重高峰发生在1234天。

即使答案是1,也要用复数形式days。

思路

:

​ 三个峰值同时出现位t

​ 案例次数为n

​ 23和28的公倍数中找一个除以23余1的数为a

​ 从223和33的公倍数中找一个除以28余1的数为b

​ 从23和28的公倍数中找一个除以33余1的数为c

已知:

(t+d)%23=a;

(t+d)%28=b;

(t+d)%33=c

(a×p+b×e+c×i)% 最小公倍数(23,28,33) =t+d

因为:

​ 使33×28×a被23除余1 5544
​ 使23×33×b被28除余1 14421。
​ 使23×28×c被33除余1 1288。

​ //23 ** 28* * 33=21252

所以:

​ 有(5544×p+14421×e+1288×i)% lcm(23,28,33) =t+d

​ 因为求最小整数解 最后结果为t= [t+21252]% 21252


#include <stdio.h>

int main() {
    int p,e,i,d;
    int n = 0;//犯案次数

    while(1){
        scanf("%d %d %d %d",&p,&e,&i,&d);
        if(p == -1 && e == -1 && i ==-1){//结束条件
            break;
        }

        //
        int a = (5544*p + 14421*e + 1288*i - d+21252)%21252;

        //如果使0 0 0 0的情况
        if(a == 0){
            a = 21252;
        }

        printf("Case %d: the next triple peak occurs in %d days.\n",++n,a);
    }
    return 0;
}

上一篇:C# ADO.NET与面向对象


下一篇:Linux Shell中单引号、双引号、反引号的区别【转载】