Description
You have N integers, A1, A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.
Input
The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of Aa, Aa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of Aa, Aa+1, ... , Ab.
Output
You need to answer all Q commands in order. One answer in a line.
Sample Input
10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4
Sample Output
4
55
9
15
思路:
之前学了线段树单点更新,所以想都没想直接一个个点更新果断超时,然后发现是区间更新orz
这是道区间更新模板题。
线段树区间更新引入了一个新东西叫做“懒标记”,它的用处是当我们进行区间更新时不用更新到根节点,比如在[1,10]区间对[1,5]区间更新,我们不需要对1~5都更新(因为目前还没用到1~5),所以我们只要暂时把值存在[1,5]这个节点就行了。如果我们需要访问[1,5]的子节点时,我们需要将暂存的值往下加。
代码:
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<queue>
#include<cmath>
#include<string>
#include<stack>
#include<set>
#include<map>
#include<vector>
#include<iostream>
#include<algorithm>
#include<sstream>
#define ll long long
const int N=100005;
const int MOD=20071027;
using namespace std;
struct node{
int l,r;
ll num,add;
}node[N<<2];
int arr[N];
void build(int l,int r,int rt){
node[rt].l=l,
node[rt].r=r;
node[rt].add=0;
if(l==r){
node[rt].num=arr[l];
return;
}
int m=(l+r)>>1;
build(l,m,rt<<1);
build(m+1,r,rt<<1|1);
node[rt].num=node[rt<<1].num+node[rt<<1|1].num;
}
void add(int rt,int l,int r,int v){
if(node[rt].l==l && node[rt].r==r){ //暂时储存
node[rt].add+=v;
return;
}
node[rt].num+=v*(r-l+1);
int m=(node[rt].l+node[rt].r)>>1;
if(r<=m){ //改变区间属于左子节点子集
add(rt<<1,l,r,v);
}
else if(l>m){ //属于右子节点子集
add(rt<<1|1,l,r,v);
}
else{ //属于左右子节点子集
add(rt<<1,l,m,v);
add(rt<<1|1,m+1,r,v);
}
}
ll query(int rt,int l,int r){
if(node[rt].l==l && node[rt].r==r){
return node[rt].num+(r-l+1)*node[rt].add;
}
node[rt].num+=(node[rt].r-node[rt].l+1)*node[rt].add; //需要继续往下找,在这里加上之前暂时存放的值
int m=(node[rt].l+node[rt].r)>>1;
add(rt<<1,node[rt].l,m,node[rt].add);
add(rt<<1|1,m+1,node[rt].r,node[rt].add);
node[rt].add=0; //暂存值归零
if(r<=m){ //查询区间属于左子节点子集
return query(rt<<1,l,r);
}
else if(l>m){ //属于右子节点子集
return query(rt<<1|1,l,r);
}
else{ //属于左右子节点子集
return query(rt<<1,l,m)+query(rt<<1|1,m+1,r);
}
}
int main(){
int n,q,a,b,c;
ll ans;
char order[2];
while(scanf("%d%d",&n,&q)!=EOF){
for(int i=1;i<=n;i++) scanf("%d",&arr[i]);
build(1,n,1);
while(q--){
scanf("%s",order);
if(order[0]=='Q'){
scanf("%d%d",&a,&b);
ans=query(1,a,b);
printf("%lld\n",ans);
}
else{
scanf("%d%d%d",&a,&b,&c);
add(1,a,b,c);
}
}
}
return 0;
}