PAT A1048 Find Coins (25 分)

Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she could only use exactly two coins to pay the exact amount. Since she has as many as 10​5​​ coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find two coins to pay for it.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (≤10​5​​, the total number of coins) and M (≤10​3​​, the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers no more than 500. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the two face values V​1​​ and V​2​​ (separated by a space) such that V​1​​+V​2​​=M and V​1​​≤V​2​​. If such a solution is not unique, output the one with the smallest V​1​​. If there is no solution, output No Solution instead.

Sample Input 1:

8 15
1 2 8 7 2 4 11 15

Sample Output 1:

4 11

**Sample Input 2:
**

7 14
1 8 7 2 4 11 15

Sample Output 2:

No Solution

实现思路:

题目要求找到V1+V2=M 且给出最小序列,这种A+B=C的题最直接想到的办法应该就是两种,二分法和哈希散列法,本题就是leetcode上的TWO SUM题型,直接采用hash来存储每个数然后判断M-V1是否存在即可,但是需要注意有重复元素的情况,例如12=6+6,这些单独考虑即可。

AC代码:

#include <iostream>
#include <vector>
using namespace std;
const int MAXN=1010;
int hashT[MAXN]= {0};

int main() {
	int n,m,val;
	cin>>n>>m;
	for(int i=0; i<n; i++) {
		scanf("%d",&val);
		hashT[val]++;
	}
	bool ans=false;
	for(int i=0; i<MAXN; i++) {
		if(hashT[i]==0) continue;
		else {
			if(i+i==m) {
				if(hashT[i]>=2) {
					cout<<i<<" "<<i;
					ans=true;
					break;
				}
			} else {
				if(hashT[m-i]>0) {
					cout<<i<<" "<<m-i;
					ans=true;
					break;
				}
			}
		}
	}
	if(!ans) cout<<"No Solution";
	return 0;
}
上一篇:2021年宜春市中考录取分数线(宜春)


下一篇:Merriam-Webster‘s Vocabular Builder ( PROB )