题目描述
读入12个整数,将他们按顺序保存为二维整数数组a的元素值,并输出这个数组。a的定义为int a[3][4]。
输入
输入为12个用空格隔开的不超过3位的整数。
输出
将数组按照3×4的格式输入,每个数占4位。
请注意行尾输出换行。样例输入 Copy
1 3 5 7 9 11 13 15 17 19 21 23样例输出 Copy
1 3 5 7 9 11 13 15 17 19 21 23
提示
一个数占4位输出可以用printf("%4d",x);
或者cout<<setw(4)<<x;
#include<bits/stdc++.h>
using namespace std;
int main(){
int a[4][5];
for(int i=1;i<=3;i++)
for(int j=1;j<=4;j++){
cin>>a[i][j];
}
for(int i=1;i<=3;i++){
for(int j=1;j<=4;j++)
cout<<setw(4)<<a[i][j];
cout<<endl;
}
}