poj 2155 Matrix (树状数组)

Matrix
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 16797   Accepted: 6312

Description

Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N).

We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a '0' then change it into '1' otherwise change it into '0'). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions.

1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2). 
2. Q x y (1 <= x, y <= n) querys A[x, y]. 

Input

The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case.

The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2 y2", which has been described above.

Output

For each querying output one line, which has an integer representing A[x, y].

There is a blank line between every two continuous test cases.

Sample Input

1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1

Sample Output

1
0
0
1

Source

POJ Monthly,Lou Tiancheng
 //4100K    438MS    C++    1052B    2014-04-01 21:00:26
/* 题意:
给出一个n*n的 二维区间,有小矩形取反操作和对某元素求值操作,对每个操作
做出处理。 树状数组:
这题和一般的树状数组不一样,一般的是对某个值更改,对某段求值,现在是刚好
反过来,利用反向思维,讲原先更新的操作用来求值, 求值的操作用来更新即可。 */
#include<stdio.h>
#include<string.h>
#define N 1005
int c[N][N];
int lowbit(int i)
{
return i&(-i);
}
int update(int x,int y)
{
int s=;
for(int i=x;i<N;i+=lowbit(i))
for(int j=y;j<N;j+=lowbit(j))
s+=c[i][j];
return s%; }
void getsum(int x,int y)
{
for(int i=x;i>;i-=lowbit(i))
for(int j=y;j>;j-=lowbit(j))
c[i][j]^=;
}
int main(void)
{
int t,n,m;
char op;
int x1,x2,y1,y2;
scanf("%d",&t);
while(t--)
{
scanf("%d%d%*c",&n,&m);
memset(c,,sizeof(c));
while(m--){
scanf("%c",&op);
if(op=='Q'){
scanf("%d%d%*c",&x1,&y1);
printf("%d\n",update(x1,y1));
}else{
scanf("%d%d%d%d%*c",&x1,&y1,&x2,&y2);
getsum(x1-,y1-);
getsum(x1-,y2);
getsum(x2,y1-);
getsum(x2,y2);
}
}
printf("\n");
}
return ;
}
上一篇:Linux 下配置 nginx + 两个 tomcat 的负载均衡


下一篇:解析汽车B2C商城网站四种盈利模式