Mr. Frog’s Problem
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 312 Accepted Submission(s): 219Problem DescriptionOne day, you, a clever boy, feel bored in your math class, and then fall asleep without your control. In your dream, you meet Mr. Frog, an elder man. He has a problem for you.He gives you two positive integers A and B, and your task is to find all pairs of integers (C, D), such that A≤C≤B,A≤D≤B and AB+BA≤CD+DC
Inputfirst line contains only one integer T (T≤125), which indicates the number of test cases. Each test case contains two integers A and B (1≤A≤B≤1018).OutputFor each test case, first output one line "Case #x:", where x is the case number (starting from 1).Then in a new line, print an integer s indicating the number of pairs you find.
In each of the following s lines, print a pair of integers C and D. pairs should be sorted by C, and then by D in ascending order.
Sample Input2
10 10
9 27Sample OutputCase #1:
1
10 10
Case #2:
2
9 27
27 9SourceRecommend
题目链接:
http://acm.hdu.edu.cn/showproblem.php?pid=5924
题目大意:
题目给定A和B(<=1018),求满足的C和D个个数,并全部输出。
题目思路:
【模拟】
+1s 这题一看样例就猜大概只有AB,BA两种情况。不妨假设C<=D
假设A/B+B/A>A/(B-1)+(B-1)/A,解得条件为B2-B>A2,所以如果要满足,则需要A2>=B2-B,而只有当A=B时满足(B>=A,B=A+1时,B2-B=A(A+1)>A2)
所以除了A=B的情况,其余都是减的,(C,D)可视为(A,B)->(A,D)->(C,D),每次只改一维,递减,所以最终也是递减的。
所以最终答案就是AB,BA 注意A=B的情况。
//HDU 5924
//by coolxxx
//#include<bits/stdc++.h>
#include<iostream>
#include<algorithm>
#include<string>
#include<iomanip>
#include<map>
#include<stack>
#include<queue>
#include<set>
#include<bitset>
#include<memory.h>
#include<time.h>
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
//#include<stdbool.h>
#include<math.h>
#pragma comment(linker,"/STACK:1024000000,1024000000")
#define min(a,b) ((a)<(b)?(a):(b))
#define max(a,b) ((a)>(b)?(a):(b))
#define abs(a) ((a)>0?(a):(-(a)))
#define lowbit(a) (a&(-a))
#define sqr(a) ((a)*(a))
#define swap(a,b) ((a)^=(b),(b)^=(a),(a)^=(b))
#define mem(a,b) memset(a,b,sizeof(a))
#define eps (1e-10)
#define J 10000
#define mod 1000000007
#define MAX 0x7f7f7f7f
#define PI 3.14159265358979323
#define N 100004
using namespace std;
typedef long long LL;
double anss;
LL aans;
int cas,cass;
LL n,m,lll,ans; int main()
{
#ifndef ONLINE_JUDGEW
// freopen("1.txt","r",stdin);
// freopen("2.txt","w",stdout);
#endif
int i,j,k;
int x,y,z;
// init();
// for(scanf("%d",&cass);cass;cass--)
for(scanf("%d",&cas),cass=;cass<=cas;cass++)
// while(~scanf("%s",s))
// while(~scanf("%d%d",&n,&m))
{
printf("Case #%d:\n",cass);
scanf("%lld%lld",&n,&m);
if(n==m)printf("%d\n%lld %lld\n",,n,m);
else printf("%d\n%lld %lld\n%lld %lld\n",,n,m,m,n);
}
return ;
}
/*
// //
*/