题目
This time, you are supposed to help us collect the data for family-owned property. Given each person’s family members, and the estate(房产)info under his/her own name, we need to know the size of each family, and the average area and number of sets of their real estate.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (<=1000).
Then N lines follow, each gives the infomation of a person who owns estate in the format:
ID Father Mother k Child1 … Childk M_estate Area
where ID is a unique 4-digit identification number for each person; Father and Mother are the ID’s of this person’s parents (if a parent has passed away, -1 will be given instead); k (0<=k<=5) is the number of children of this person; Childi’s are the ID’s of his/her children; M_estate is the total number of sets of the real estate under his/her name; and Area is the total area of his/her estate.
Output Specification:
For each case, first print in a line the number of families (all the people that are related directly or indirectly are considered in the same family). Then output the family info in the format: ID M AVG_sets AVG_area
where ID is the smallest ID in the family; M is the total number of family members; AVG_sets is the average number of sets of their real estate; and AVG_area is the average area. The average numbers must be accurate up to 3 decimal places. The families must be given in descending order of their average areas, and in ascending order of the ID’s if there is a tie.
Sample Input:
10
6666 5551 5552 1 7777 1 100
1234 5678 9012 1 0002 2 300
8888 -1 -1 0 1 1000
2468 0001 0004 1 2222 1 500
7777 6666 -1 0 2 300
3721 -1 -1 1 2333 2 150
9012 -1 -1 3 1236 1235 1234 1 100
1235 5678 9012 0 1 50
2222 1236 2468 2 6661 6662 1 300
2333 -1 3721 3 6661 6662 6663 1 100
Sample Output:
3
8888 1 1.000 1000.000
0001 15 0.600 100.000
5551 4 0.750 100.000
题目分析
给定每个⼈的家庭成员和其⾃⼰名下的房产,请你统计出每个家庭的⼈⼝数、⼈均房产⾯积及房产套数。⾸先在第⼀⾏输出家庭个数(所有有亲属关系的⼈都属于同⼀个家庭)。随后按下列格式输出每个家庭的信息:家庭成员的最⼩编号 家庭⼈⼝数 ⼈均房产套数 ⼈均房产⾯积。其中⼈均值要求保留⼩数点后3位。家庭信息⾸先按⼈均⾯积降序输出,若有并列,则按成员编号的升序输出。
解题思路
- 并查集,将所有属于同一家庭的成员合并到一个集合。---需借助两个int数组father并操作需要,visit其下标对应成员id
1.1 思想:对结构体进行并查集操作比较麻烦,可以对结构体的id进行并查集操作
1.2 visit数组记录的是输入数据的成员id,所以很多位置都是空的,为了跳过这些空位置,需要visit记录所有输入的id - 统计并查集各个集合的数据,并排序打印
2.1 将各个集合的数据保存到ans结构体数组中
code
#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
int const maxn=10000;
int father[maxn];
bool visit[maxn];
struct DATA {
int id,fid,mid,num,area;
int cid[10];
} data[1005];
struct node {
int id,people;
double num,area;
bool flag = false;
} ans[maxn]; //索引为id
int find(int x) {
int e = x;
while(x!=father[x]) {
x=father[x];
}
while(e!=father[e]) {
int temp = father[e];
father[e]=x;
e = temp;
}
return x;
}
void Union(int a,int b) {
int fa=find(a);
int fb=find(b);
if(fa>fb) {
father[fa]=fb;
} else if(fa<fb) {
father[fb]=fa;
}
}
bool cmp(node &a,node & b) {
if(a.area!=b.area) {
return a.area>b.area;
} else {
return a.id<b.id;
}
}
int main(int argc,char * argv[]) {
int n,k,cnt=0;
scanf("%d",&n);
for(int i=0; i<maxn; i++)father[i]=i; //初始化father数组
for(int i=0; i<n; i++) {
scanf("%d %d %d %d", &data[i].id,&data[i].fid,&data[i].mid,&k);
visit[data[i].id]=true;
if(data[i].fid!=-1) {
visit[data[i].fid]=true;
Union(data[i].fid,data[i].id);
}
if(data[i].mid!=-1) {
visit[data[i].mid]=true;
Union(data[i].mid,data[i].id);
}
for(int j=0; j<k; j++) {
scanf("%d", &data[i].cid[j]);
visit[data[i].cid[j]]=true;
Union(data[i].cid[j],data[i].id);
}
scanf("%d %d",&data[i].num,&data[i].area);
}
for(int i=0; i<n; i++) {
int id=find(data[i].id);
ans[id].id=id;
ans[id].num+=data[i].num;
ans[id].area+=data[i].area;
ans[id].flag=true; //是根
}
for(int i=0; i<maxn; i++) {
if(visit[i])
ans[find(i)].people++;
if(ans[i].flag) {
cnt++;
}
}
for(int i=0; i<maxn; i++) {
if(ans[i].flag) {
ans[i].num=(double)(ans[i].num*1.0/ans[i].people);
ans[i].area=(double)(ans[i].area*1.0/ans[i].people);
}
}
sort(ans,ans+maxn,cmp);
printf("%d\n", cnt);
for(int i = 0; i < cnt; i++)
printf("%04d %d %.3f %.3f\n", ans[i].id, ans[i].people, ans[i].num,ans[i].area);
return 0;
}