1058 A+B in Hogwarts (20分)

 

If you are a fan of Harry Potter, you would know the world of magic has its own currency system -- as Hagrid explained it to Harry, "Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it's easy enough." Your job is to write a program to compute A+B where A and B are given in the standard form of Galleon.Sickle.Knut (Galleon is an integer in [0,10​7​​], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).

Input Specification:

Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input.

Sample Input:

3.2.1 10.16.27

Sample Output:

14.1.28

 

#include "stdio.h"
#include "iostream"

using namespace std;

int main() {
    long long a, b, c, d, e, f;    //本题数据要用long long 否则样例会过不去
    scanf("%ld.%ld.%ld %ld.%ld.%ld", &a, &b, &c, &d, &e, &f);
    long long sum = d * 17 * 29 + e * 29 + f + (a * 17 * 29 + b * 29 + c);
    long long G = sum / 493;
    long long S = sum % 493 / 29;
    long long K = sum % 493 % 29;
    cout << G << "." << S << "." << K;
}

 

上一篇:命令汇总


下一篇:LINUX动态库(.SO)搜索路径(目录)设置方法